re = /(\/\*[\w\'\s\r\n\*]*\*\/)|(\/\/[\w\s\']*)/
str = '/*api.runTests(true);*/
//asdfasdf
/*
field.activate(true);
*
*/
/*
*/
/****
* Common multi-line comment style.
****/
/****
* Another common multi-line comment style.
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end