using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?:(?<!\w)'(\w.*?)'(?!\w)|\""(\w.*?)\""(?!\w)))";
string input = @"'Well, I've tried to say ""How Doth the Little Busy Bee,"" but it all came different!' Alice replied in a very melancholy voice. She continued, 'I'll try again.'
""Well, I've tried to say 'How Doth the Little Busy Bee,' but it all came different!"" Alice replied in a very melancholy voice. She continued, ""I'll try again.""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}