$re = '/(?=(?:(?<!\w)\'(\w.*?)\'(?!\w)|\"(\w.*?)\"(?!\w)))/mi';
$str = '\'Well, I\'ve tried to say "How Doth the Little Busy Bee," but it all came different!\' Alice replied in a very melancholy voice. She continued, \'I\'ll try again.\'
"Well, I\'ve tried to say \'How Doth the Little Busy Bee,\' but it all came different!" Alice replied in a very melancholy voice. She continued, "I\'ll try again."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);