import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(?:(?<!\\w)'(\\w.*?)'(?!\\w)|\\\"(\\w.*?)\\\"(?!\\w)))";
final String string = "'Well, I've tried to say \"How Doth the Little Busy Bee,\" but it all came different!' Alice replied in a very melancholy voice. She continued, 'I'll try again.'\n\n"
+ "\"Well, I've tried to say 'How Doth the Little Busy Bee,' but it all came different!\" Alice replied in a very melancholy voice. She continued, \"I'll try again.\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}