import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b.*([a-z]\\d+[a-z]|[a-z]{2,}\\d|\\d[a-z]{2,}).*?\\b";
final String string = "These would be valid: \n"
+ "1234567890aA 1234567890A\n"
+ "123A4567890a 1234567890\n"
+ "A1234567890a 1234567a890\n"
+ "John12 a1234567890\n"
+ "qw123123 1a\n"
+ "John20 aa\n"
+ "20John\n"
+ "1aa\n\n"
+ "These would not:\n"
+ "1234567890A\n"
+ "1234567890\n"
+ "1234567a890\n"
+ "a1234567890\n"
+ "1a\n"
+ "aa";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}