const regex = /\b.*([a-z]\d+[a-z]|[a-z]{2,}\d|\d[a-z]{2,}).*?\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b.*([a-z]\\d+[a-z]|[a-z]{2,}\\d|\\d[a-z]{2,}).*?\\b', 'gi')
const str = `These would be valid:
1234567890aA 1234567890A
123A4567890a 1234567890
A1234567890a 1234567a890
John12 a1234567890
qw123123 1a
John20 aa
20John
1aa
These would not:
1234567890A
1234567890
1234567a890
a1234567890
1a
aa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}