use strict;
my $str = 'These would be valid:
1234567890aA 1234567890A
123A4567890a 1234567890
A1234567890a 1234567a890
John12 a1234567890
qw123123 1a
John20 aa
20John
1aa
These would not:
1234567890A
1234567890
1234567a890
a1234567890
1a
aa';
my $regex = qr/\b.*([a-z]\d+[a-z]|[a-z]{2,}\d|\d[a-z]{2,}).*?\b/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}