package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<iframe\s+(?:"[\S\s]*?"|'[\S\s]*?'|[^>]*?)+>\s*</iframe>)(?:(?:[\S\s]*?(<iframe\s+(?:"[\S\s]*?"|'[\S\s]*?'|[^>]*?)+>\s*</iframe>))|)`)
var str = `Passed, Group 2 is NULL
<iPframe ..A...></iframe>
<iframe ...B..></iframe>
<iXframe ...C..></iframe>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}