const regex = new RegExp('(<iframe\\s+(?:"[\\S\\s]*?"|\\'[\\S\\s]*?\\'|[^>]*?)+>\\s*</iframe>)(?:(?:[\\S\\s]*?(<iframe\\s+(?:"[\\S\\s]*?"|\\'[\\S\\s]*?\\'|[^>]*?)+>\\s*</iframe>))|)', 'gm')
const str = `Passed, Group 2 is NULL
<iPframe ..A...></iframe>
<iframe ...B..></iframe>
<iXframe ...C..></iframe>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}