$re = '`(<iframe\s+(?:"[\S\s]*?"|\'[\S\s]*?\'|[^>]*?)+>\s*</iframe>)(?:(?:[\S\s]*?(<iframe\s+(?:"[\S\s]*?"|\'[\S\s]*?\'|[^>]*?)+>\s*</iframe>))|)`m';
$str = 'Passed, Group 2 is NULL
<iPframe ..A...></iframe>
<iframe ...B..></iframe>
<iXframe ...C..></iframe>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);