#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*=([^\r\n=]+)=[^=\r\n]+$|[^\r\n=]+)"
Local $sString = "I have candy='4' and ice cream = 'vanilla'" & @CRLF & _
"I have candy='4' and ice cream = 'vanilla' and house='big'" & @CRLF & _
"test test ='test test test'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")