package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.*=([^\r\n=]+)=[^=\r\n]+$|[^\r\n=]+)`)
var str = `I have candy='4' and ice cream = 'vanilla'
I have candy='4' and ice cream = 'vanilla' and house='big'
test test ='test test test'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}