import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<id>\\d+)_(?<version>v\\d+)_(?P<description>\\S+)_(?P<quality>(?i)Q4A|Q6A|Q8C|QXB).(?<extension>(?i)mp4|webm)";
final String string = "# matches\n"
+ "00001_v1234_this-iS-a-1234-description_qxb.mp4\n"
+ "12345_v1234_this-iS-a-1234-Description_qxb.weBm\n\n"
+ "12345_v2_this-is-a-description_Q4a.mp4\n"
+ "12345_v2_this-is-a-description_q6A.mp4\n"
+ "12345_v2_this-is-a-description_Q8C.mp4\n"
+ "12345_v2_this-is-a-description_qxb.mp4\n\n\n"
+ "# no matches\n"
+ "12-34_v2_this-is-a-description_Q8C.mp4\n"
+ "12345_v2_this-is-a-description_Q8C.mp3\n"
+ "12345_v2.0_this-is-a-description_qxb.mp4\n"
+ "12345_v2_this-is-a-description_qxA.mp4\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}