// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<id>\d+)_(?<version>v\d+)_(?P<description>\S+)_(?P<quality>(?i)Q4A|Q6A|Q8C|QXB).(?<extension>(?i)mp4|webm)").unwrap();
let string = "# matches
00001_v1234_this-iS-a-1234-description_qxb.mp4
12345_v1234_this-iS-a-1234-Description_qxb.weBm
12345_v2_this-is-a-description_Q4a.mp4
12345_v2_this-is-a-description_q6A.mp4
12345_v2_this-is-a-description_Q8C.mp4
12345_v2_this-is-a-description_qxb.mp4
# no matches
12-34_v2_this-is-a-description_Q8C.mp4
12345_v2_this-is-a-description_Q8C.mp3
12345_v2.0_this-is-a-description_qxb.mp4
12345_v2_this-is-a-description_qxA.mp4
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}