use strict;
my $str = '# matches
00001_v1234_this-iS-a-1234-description_qxb.mp4
12345_v1234_this-iS-a-1234-Description_qxb.weBm
12345_v2_this-is-a-description_Q4a.mp4
12345_v2_this-is-a-description_q6A.mp4
12345_v2_this-is-a-description_Q8C.mp4
12345_v2_this-is-a-description_qxb.mp4
# no matches
12-34_v2_this-is-a-description_Q8C.mp4
12345_v2_this-is-a-description_Q8C.mp3
12345_v2.0_this-is-a-description_qxb.mp4
12345_v2_this-is-a-description_qxA.mp4
';
my $regex = qr/(?P<id>\d+)_(?<version>v\d+)_(?P<description>\S+)_(?P<quality>(?i)Q4A|Q6A|Q8C|QXB).(?<extension>(?i)mp4|webm)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}