#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\((?:[^)]*)(?:[^(]*)\))|([\w.,'"!?\\-]+)|(\s+)"
Local $sString = "The quick brown fox ((jumps (down)) over the) lazy dog." & @CRLF & _
"" & @CRLF & _
"'hello world (some test) (some more test), good bye world."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")