$re = '/(\((?:[^)]*)(?:[^(]*)\))|([\w.,\'"!?\\\\-]+)|(\s+)/m';
$str = 'The quick brown fox ((jumps (down)) over the) lazy dog.
\'hello world (some test) (some more test), good bye world.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);