// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(\((?:[^)]*)(?:[^(]*)\))|([\w.,'"!?\\-]+)|(\s+)"#).unwrap();
let string = "The quick brown fox ((jumps (down)) over the) lazy dog.
'hello world (some test) (some more test), good bye world.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}