using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\pL)(أحمد|محمد|حسن|محسن|على|حاتم|مصطفى)(?!\pL)";
string input = @"الاسم الاول احمد ثم مصطفى ثم حاتم ثم محسن";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}