$re = '/(?<!\pL)(أحمد|محمد|حسن|محسن|على|حاتم|مصطفى)(?!\pL)/iu';
$str = 'الاسم الاول احمد ثم مصطفى ثم حاتم ثم محسن';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);