const regex = /(?<!\pL)(أحمد|محمد|حسن|محسن|على|حاتم|مصطفى)(?!\pL)/iu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\pL)(أحمد|محمد|حسن|محسن|على|حاتم|مصطفى)(?!\\pL)', 'iu')
const str = `الاسم الاول احمد ثم مصطفى ثم حاتم ثم محسن`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}