using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(?<id>\d+)-[^\/]+\/?";
string input = @"https://thehill.com/homenews/3705204-election-central-2022-live-results-from-senate-house-governor-races/random-stuff-for-ben-to-see/";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}