const regex = /\/(?<id>\d+)-[^\/]+\/?/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(?<id>\\d+)-[^\\\/]+\\\/?', 'm')
const str = `https://thehill.com/homenews/3705204-election-central-2022-live-results-from-senate-house-governor-races/random-stuff-for-ben-to-see/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}