re = /\/(?<id>\d+)-[^\/]+\/?/m
str = 'https://thehill.com/homenews/3705204-election-central-2022-live-results-from-senate-house-governor-races/random-stuff-for-ben-to-see/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end