using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""name\"":\s+\""(?<name>[^\""]+)\"",\s+\""result\"":\s+(?<result>\w+)";
string input = @"{""name"": ""abc def - 123"", ""result"": true}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}