re = /\"name\":\s+\"(?<name>[^\"]+)\",\s+\"result\":\s+(?<result>\w+)/m
str = '{"name": "abc def - 123", "result": true}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end