import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\n"
+ "(?:\n"
+ " Length\\ +(?<Length>\\d+(?:\\.\\d+)?|\\d+-\\d+\\/\\d+)\\ +(?:in|ft|cm|m)|\n"
+ " Width\\ +(?<Width>\\d+(?:\\.\\d+)?)\\ +(?:in|ft|cm|m)|\n"
+ " Weight\\ +(?<Weight>\\d+)\\ +(?:oz|lb|g|kg)\n"
+ ")\n"
+ "\\b";
final String string = "Width 3.5 in\n"
+ "Weight 10 kg\n"
+ "Length 6-3/4 m\n\n"
+ "Note I've set the 'x' (extended) flag to make it easier to view the regex. \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}