import re
regex = re.compile(r"""
\b
(?:
Length\ +(?<Length>\d+(?:\.\d+)?|\d+-\d+\/\d+)\ +(?:in|ft|cm|m)|
Width\ +(?<Width>\d+(?:\.\d+)?)\ +(?:in|ft|cm|m)|
Weight\ +(?<Weight>\d+)\ +(?:oz|lb|g|kg)
)
\b
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("Width 3.5 in\n"
"Weight 10 kg\n"
"Length 6-3/4 m\n\n"
"Note I've set the 'x' (extended) flag to make it easier to view the regex. \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")