import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z_][\\da-zA-Z_]*=([+*\\/-])\\1[a-zA-Z_][\\da-zA-Z_]*$";
final String string = "k=++g677\n"
+ "k=--j77\n"
+ "k=++gfrf677frfr\n\n"
+ "k++\n"
+ "k=++@ff\n"
+ "k=\n"
+ "k=++**";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}