re = /^[a-zA-Z_][\da-zA-Z_]*=([+*\/-])\1[a-zA-Z_][\da-zA-Z_]*$/m
str = 'k=++g677
k=--j77
k=++gfrf677frfr
k++
k=++@ff
k=
k=++**'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end