$re = '/^[a-zA-Z_][\da-zA-Z_]*=([+*\/-])\1[a-zA-Z_][\da-zA-Z_]*$/m';
$str = 'k=++g677
k=--j77
k=++gfrf677frfr
k++
k=++@ff
k=
k=++**';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);