import re
regex = re.compile(r"moduleName: [\"']?github\.com\/(?<depName>[\w\-]+\/[\w\-\.]+)[\"']?,?\s+version:\s+[\"']?(?<currentValue>[_\-\.\w]+)[\"']?", flags=re.MULTILINE)
test_str = (" plugins:\n"
" plugin-name: { moduleName: github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin, version: v1.3.0 }\n\n"
" plugins:\n"
" plugin-name:\n"
" moduleName: \"github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin\"\n"
" version: 'v1.3.0'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")