re = /moduleName: ["']?github\.com\/(?<depName>[\w\-]+\/[\w\-\.]+)["']?,?\s+version:\s+["']?(?<currentValue>[_\-\.\w]+)["']?/m
str = ' plugins:
plugin-name: { moduleName: github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin, version: v1.3.0 }
plugins:
plugin-name:
moduleName: "github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin"
version: \'v1.3.0\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end