$re = '/(?(DEFINE)
(?<expr> \w+ | \'[\w\s]*\' | "[\s\w]*" | \(\s*(?&expr)\s*\) )
(?<clause> (?&expr)\s*=\s*(?&expr) )
(?<case> case \s+ when \s+ (?&clause) \s+ then \s+ (?&expr) \s+ else \s+ (?&expr) \s+ end)
)
(?i)(\s* (?&case) \s*)+/mxi';
$str = 'iduser + CaSe WhEn ("end") = 0 THEN \'CASE WHEN\' ELSE \' END \' END + sum(iduser ) + CASE WHEN LANGUAGE = 3 THEN 4 ELSE 5 END';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);