$re = '/^((?!local).)*$/m';
$str = 'http://stage-plan.com
http://www.stage-plan.com
https://stage-plan.com
https://www.stage-plan.com
http://localhost/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);