re = /^((?!local).)*$/m
str = 'http://stage-plan.com
http://www.stage-plan.com
https://stage-plan.com
https://www.stage-plan.com
http://localhost/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end