package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+\s([a-z]+\s?)+`)
var str = `1923 The lazy dog Jumped
1923 the lazy dog jumped`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}