re = /^[0-9]+\s([a-z]+\s?)+/m
str = '1923 The lazy dog Jumped
1923 the lazy dog jumped'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end