$re = '/^[0-9]+\s([a-z]+\s?)+/m';
$str = '1923 The lazy dog Jumped
1923 the lazy dog jumped';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);