import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\p{Lu}\\p{Ll}{3,50}$";
final String string = "dddd\n"
+ "Ddddd\n"
+ "ddd\n"
+ "SSSSS\n"
+ "Ddd\n"
+ "Ddddddddddddddddddddddddddddddddddddddddd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}