re = /^\p{Lu}\p{Ll}{3,50}$/m
str = 'dddd
Ddddd
ddd
SSSSS
Ddd
Ddddddddddddddddddddddddddddddddddddddddd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end