$re = '/^\p{Lu}\p{Ll}{3,50}$/m';
$str = 'dddd
Ddddd
ddd
SSSSS
Ddd
Ddddddddddddddddddddddddddddddddddddddddd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);