#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!s?([/|@#]).+?\1.*?\1.*?\1)s?([/|@#]).+?\2.*?\2[gi]?[gi]?\d?\d?$"
Local $sString = "shuuld be match:" & @CRLF & _
"/.//" & @CRLF & _
"s/.//" & @CRLF & _
"/.//g" & @CRLF & _
"/.//i" & @CRLF & _
"/././gi" & @CRLF & _
"/one-or-more/anything/" & @CRLF & _
"/one-or-more/anything/g/3" & @CRLF & _
"/one-or-more/anything/i" & @CRLF & _
"/one-or-more/anything/gi/99" & @CRLF & _
"s/one-or-more/anything/g/4" & @CRLF & _
"s/one-or-more/anything/i" & @CRLF & _
"s/one-or-more/anything/gi/54" & @CRLF & _
"" & @CRLF & _
"should not be match:" & @CRLF & _
"/.///" & @CRLF & _
"s/.///" & @CRLF & _
"s/././/" & @CRLF & _
"/anything/anything/anything/anything/" & @CRLF & _
"s/anything/anything/anything/" & @CRLF & _
"s/anything/anything/anything/g" & @CRLF & _
"s/anything/anything/anything/i" & @CRLF & _
"s/anything/anything/anything/gi" & @CRLF & _
"/anything/anything/anything/gi" & @CRLF & _
"/anything/anything/anything/g" & @CRLF & _
"/anything/anything/anything/i"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")