using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!s?([/|@#]).+?\1.*?\1.*?\1)s?([/|@#]).+?\2.*?\2[gi]?[gi]?\d?\d?$";
string input = @"shuuld be match:
/.//
s/.//
/.//g
/.//i
/././gi
/one-or-more/anything/
/one-or-more/anything/g/3
/one-or-more/anything/i
/one-or-more/anything/gi/99
s/one-or-more/anything/g/4
s/one-or-more/anything/i
s/one-or-more/anything/gi/54
should not be match:
/.///
s/.///
s/././/
/anything/anything/anything/anything/
s/anything/anything/anything/
s/anything/anything/anything/g
s/anything/anything/anything/i
s/anything/anything/anything/gi
/anything/anything/anything/gi
/anything/anything/anything/g
/anything/anything/anything/i";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}