# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!s?([/|@#]).+?\1.*?\1.*?\1)s?([/|@#]).+?\2.*?\2[gi]?[gi]?\d?\d?$"
test_str = ("shuuld be match:\n"
"/.//\n"
"s/.//\n"
"/.//g\n"
"/.//i\n"
"/././gi\n"
"/one-or-more/anything/\n"
"/one-or-more/anything/g/3\n"
"/one-or-more/anything/i\n"
"/one-or-more/anything/gi/99\n"
"s/one-or-more/anything/g/4\n"
"s/one-or-more/anything/i\n"
"s/one-or-more/anything/gi/54\n\n"
"should not be match:\n"
"/.///\n"
"s/.///\n"
"s/././/\n"
"/anything/anything/anything/anything/\n"
"s/anything/anything/anything/\n"
"s/anything/anything/anything/g\n"
"s/anything/anything/anything/i\n"
"s/anything/anything/anything/gi\n"
"/anything/anything/anything/gi\n"
"/anything/anything/anything/g\n"
"/anything/anything/anything/i")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.