using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<soap_envelope><soap:Envelope.*\/soap:Envelope>)";
string input = @" {""severity"":""DEBUG"",""logger"":""org.mule.module.http.internal.HttpMessageLogger"",""thread"":""[dmvproxy-1.0.2-RELEASE].HTTP_Listener_Configuration.worker.790"",""message"":""LISTENER\nPOST \/inolrsproxy HTTP\/1.1\r\nContent-Type: text\/xml; charset=UTF-8\r\nAccept: *\/*\r\nUser-Agent: Apache CXF 3.1.4\r\nX-Takipi-SN: 18480\r\nCache-Control: no-cache\r\nPragma: no-cache\r\nHost: dmv-proxy.dmv-proxy.rancher.internal:8081\r\nConnection: keep-alive\r\nContent-Length: 3413\r\n\r\n<soap:Envelope xmlns:soap=\""http:\/\/schemas.xmlsoap.org\/soap\/envelope\/\""><soap:Body><test>testvalue<\/test><\/soap:Body><\/soap:Envelope>""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}