import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<soap_envelope><soap:Envelope.*\\/soap:Envelope>)";
final String string = " {\"severity\":\"DEBUG\",\"logger\":\"org.mule.module.http.internal.HttpMessageLogger\",\"thread\":\"[dmvproxy-1.0.2-RELEASE].HTTP_Listener_Configuration.worker.790\",\"message\":\"LISTENER\\nPOST \\/inolrsproxy HTTP\\/1.1\\r\\nContent-Type: text\\/xml; charset=UTF-8\\r\\nAccept: *\\/*\\r\\nUser-Agent: Apache CXF 3.1.4\\r\\nX-Takipi-SN: 18480\\r\\nCache-Control: no-cache\\r\\nPragma: no-cache\\r\\nHost: dmv-proxy.dmv-proxy.rancher.internal:8081\\r\\nConnection: keep-alive\\r\\nContent-Length: 3413\\r\\n\\r\\n<soap:Envelope xmlns:soap=\\\"http:\\/\\/schemas.xmlsoap.org\\/soap\\/envelope\\/\\\"><soap:Body><test>testvalue<\\/test><\\/soap:Body><\\/soap:Envelope>\"}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}