use strict;
my $str = '5494398 70008 \'order # 5494398 Product#: 70008
5001447452 \' should be ignored
6415366 OSW SHIP 70052 \'order # 6415366 Product#: 70052
6567598y7058 Nov 20 \'order # 6567598 Product#: 7058
OSW SHIP 70054 RH STRONGBACKS \'order # N/A Product#: 70054
OSW HS 70052 70053 \'order # N/A Product#: 70008
6511534 04450 \'order # 6511534 Product#:either 04450 or 0445 (this is only case)
6511538 0046 \'order # 6511538 Product#: 0046
0046 6387125 \'order # 6387125 Product#: 0046
OSW 70032 \'order # N/A Product#: 70032
OSW HEX Blots 046 047 048 049 \'order # N/A Product#: 064 & 047 & 048 & 049 (4 matches)';
my $regex = qr/(?:^|\D)([790]\d{1,4})(?!\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}