import Foundation
let pattern = #"(?:^|\D)([790]\d{1,4})(?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
5494398 70008 'order # 5494398 Product#: 70008
5001447452 ' should be ignored
6415366 OSW SHIP 70052 'order # 6415366 Product#: 70052
6567598y7058 Nov 20 'order # 6567598 Product#: 7058
OSW SHIP 70054 RH STRONGBACKS 'order # N/A Product#: 70054
OSW HS 70052 70053 'order # N/A Product#: 70008
6511534 04450 'order # 6511534 Product#:either 04450 or 0445 (this is only case)
6511538 0046 'order # 6511538 Product#: 0046
0046 6387125 'order # 6387125 Product#: 0046
OSW 70032 'order # N/A Product#: 70032
OSW HEX Blots 046 047 048 049 'order # N/A Product#: 064 & 047 & 048 & 049 (4 matches)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)