use strict;
my $str = 'ИВАН ИВАНОВ ИВАНОВИЧ';
my $regex = qr/([а-яА-Яa-zA-Z])[а-яА-Яa-zA-Z]* ([а-яА-Яa-zA-Z])[а-яА-Яa-zA-Z]* ([а-яА-Яa-zA-Z])[а-яА-Яa-zA-Z]*/mp;
my $subst = '$1 $2 $3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";